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Web WordPro Literature Review

2.5 Analysis on existing word processor
Although there are number of word processor, only two of them have been chosen and

evaluated for further details and surveys in order to decide the project synthesis. These

tools are Notepad and WordPad.

Notepad and WordPad are chosen because they are very simple, yet adequate word
processor that comes packaged with Microsoft Windows 95/98/2000. Each provides
basic text editing capability, but you may have tasks that are better suited for one editor

over the other.

TS B AN I A S A R s i <

Figure 2.1: Layout For Notepad
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Web WordPro Methodology & System Analysis

Chapter 3
Methodology and System Analysis

3.1 Project Development Methodology

There are many type of development model. The model that is used to develop the

system is the ‘Waterfall’ model. The diagram below is the “Waterfall’ model [6].

Requirements

definition '

A
System & |
software
design
A
Implementation
& unit testing |
4 Integration &
system
testing ‘
T Operation &
maintenance

Figure 3.1: Waterfall model
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Web WordPro

v
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Figure 3 3: User Structure Chart
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Web WordPro Methodology & System Analysts
"~ Member ID
Password 3
Introduction of Web
r Losin WordPro
Registration
Change Password
Figure 3.7: User Login Screen
File Menu Edit Menu Print Menu Format menu Help
Scrolling Text Box

Figure 3.8: Word Processing Screen







Web WordPro Methodology & System Analysis

3.9 Expected Outcome

There are two main module and five sub modules in Web WordPro.

Main Login Screen

$n

Word Processing Main
Screen

Format menu

4—»  File menu

Edit Menu

Help Menu Print Menu

Figure 3.9: Expected Outcome
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Web WordPro System Implementation

4.2 Development Environment

Development of a system definitely will be impacted by development environment.
Developing a system with using suitable hardware and software will not only help to
speed up the performance, but also determine the successful of the project. Good
environment also helps the designer to develop the system in a convenience
condition. The hardware and software tools which are use to develop the enure

system are as discuss below.

42.1 Hardware Requirements
Below is the list of hardware used during the development of the system:
e Pentium [I 300 Mhz Processor
s 96 MBRAM
e 10 GB Harddisk space
* 24 bit true color SVGA
* 56 k internet/externet modem connection

e 1.44 floppy disk drive

58






















Web WordPro System Implementation

4.5.2 External Documentation

Extemnal flocumcntation is part of the overall system documentation. At the time the
features are written, much of the rationalé for the function structure and flow has
already been detailed in the design documents section. Not only programmer can
refer external documentation but also by those who may never look at the actual

source code. (Refer to appendix A)
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Introduction

Web WordPro
Attractiveness v Good
Color combination v Good
Page layout/design/frames v Good
Hyperlink performance v Good
Readability of text v Good
Response time o Good
Security v Fair
Table 5.2: Overall unit testing and system testing
Function Tested Evaluated
Retrieval of data 4 Good
User login €& Good
Update database 7 Good
Feedback from functionality v Good
Prevention of unauthorized v Fair
Confirmation form v Good

Table 5.3: Overall login module testing and system testing (database testing)
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Web WordPro System evaluation & conclusions

I have gained invaluable knowledge and experience as the project progresses. It
makes me appreciate the knowledge that I have learnt during the three years of study
in University Malaya because this knowledge was very useful for me while

developing the system.

[ also realize that tertiary education can only provide the foundation of knowledge of
computer science and information technology to me. There are more things to learmn
and experience in the future working environment. Thus, I have to equip myself

continuously with new information and skills.

Finally, I feel very successful after developing Web WordPro alone. Although Web
WordPro is well operates at the moment, it still need some enhancement to make it

more sophisticated.
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Web WordPro

Appendix A

File name: index.htmi

Programmer : Wong Yeu Wen
Matrix No. : WET 98062 iy
Objective : Default page for Web WordPro and includes introduction of the
system.
Version 1.0 : Written on 01/01/2001
Links . checklogin.asp
Register.asp
New pwd.html
File name: checklogin.asp
Programmer : Wong Yeu Wen
Matrix No. : WET 98062
Objective : To valid the username and password
Version 1.0 : Written on 01/01/2001
Links . process.asp
Index.html

File name: register.asp

Programmer
Matrix No.
Objective
Version 1.0
Links

: Wong Yeu Wen

: WET 98062

: To fill in the registration form
: Written on 01/01/2001

: adduser.asp
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Appendix A

File name: adduser.asp

Programmer
Matrix No.
Objective
Version 1.0
Links

: Wong Yeu Wen

: WET 98062 =
: Add new user’s detail into the database
: Written on 01/01/2001

. process.asp

Checklogin.asp

File name: new_pwd.html

Programmer
Matrix No.

Objective

Version 1.0
Links

: Wong Yeu Wen
: WET 98062
: To allow user to fill in the confirmation form to change the

password

: Written on 01/01/2001
: change pwd.asp

File name: change_pwd.asp

Programmer
Matrix No.
Objective
Version 1.0
Links

: Wong Yeu Wen

: WET 98062

: To change the user’s password
: Written on 01/01/2001

: register.asp

index.html
checklogin.asp

process.asp
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Appendix A

File name: o_filel.asp

Programmer
Matrix No.
Objective
Version 1.0
Links

: Wong Yeu Wen

: WET 98062

: To fill in the file name and paths which the file want to open
: Written on 01/01/2001

: process.asp

File name: saveasl.asp

Programmer
Matrix No.

Objective
Version 1.0
Links

: Wong Yeu Wen

: WET 98062

: To fill in the file name and the paths
. Written on 01/01/2001

. saveas2.asp

File name: saveas2.asp

Programmer
Matrix No.
Objective
Version 1.0
Links

: Wong Yeu Wen

: WET 98062

: To save a new file in a specific directories
: Written on 01/01/2001

. saveasl.asp
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Web WordPro

Appendix A

File name: process.asp

Programmer
Matrix No.

Objective

Version 1.0
Links

Functions called

: Wong Yeu Wen
: WET 98062
: Main page for WebWordPro which allow user to insert text in

textarea, create a new document, to save a document, open a

document, text editing, text formatting and printing.

: Written on 01/01/2001
o _filel.asp

saveas|.asp,
saveas2.asp
font1.asp
logout.asp
helpdefault.asp
about1.html

preview.asp

: getActiveText(e)

getemptyText(e)
copyfile()
getdeletetext(e)
cutfile()
deletefile()
CountWords (this_field, alertWords, alertChars)
cleanCAPS(str)
pick(obj)
unpick(obj)
save as()
file_print()
preview()



Web WordPro

Appendix A

about1()
contents()

File name: logout.asp

Programmer : Wong Yeu Wen

Matrix No. : WET 98062

Objective : To inform the user with a message “logout”™
Version 1.0 : Written on 01/01/2001

Links . Index.html

File name: aboutl.htm

Programmer : Wong Yeu Wen

Matrix No. : WET 98062

Objective : To show the information about Web WordPro
Version 1.0 » Written on 01/01/2001

File name: fontl.asp

Programmer : Wong Yeu Wen

Matrix No. : WET 98062

Objective : To set the font type

Version 1.0 : Written on 01/01/2001

Links : register.asp
index.html
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Web WordPro Appendix A

checklogin.asp

process.asp

File name: helpdefault.asp

Programmer : Wong Yeu Wen
Matrix No. : WET 98062
Objective : Main screen for on-line help. To create two frames.

Nav_home.html will loaded in the first frame, while
mainpage.html will load in he second frame.

Version 1.0 : Written on 01/01/2001
Links : nav_home.htm
mainpage.asp

File name: nav_home.asp

Programmer - Wong Yeu Wen
Matrix No. : WET 98062
Objective : To link to other help files
Version 1.0 : Written on 01/01/2001
Links : mainpage.html

help2.asp

help3.asp

help4.asp

help5.asp

help6.asp

help7.asp



Web WordPro Appendix A

File name: mainpage.html, help2.asp, help3.asp, help4.asp, helpS.asp, help6.asp,

hglp‘?.asp
Programmer : Wong Yeu Wen
Matrix No. : WET 98062
Objective : On-line help screen for user
Version 1.0 : Written on 01/01/2001
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Web WordPro Appendix B

Help Topies Using Web WordPro to edit short
e documents

Using Wi
Web WordPro is a text editor for short documents.
Croata You can format documents in WordPad with various font.

The default margin for a new document is

Save a document Top: 10 inches

Bottom: 1.0 inches
Left:0.75 inches.
|Copy, cut, paste & The defauit : :
_ paper size for a new document is
delete document letter size (8 1/2x 11 inches)

Figure B1: Help screen for users — using Web WordPro
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Web WordPro Appendix B

Help Topics To create a new document On the File
menu, click New,
sing Web WardPro 1. Click the type of file you want te create, click OK, and
. then begin typing.
Create a document 2. To save the file, click the File menu, click Save, and

then type a name for the file in the File name box.

#gm. _a document e

When you start Web WordPre, you can justbegin typing
Open a document in the window.

Then when you save the file, you can choose the format of

'gm.m& the file in the Save as format hex.
delete document

Figure B2: Help screen for users — create a document
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Web WordPro Appendix B

e ML L.

A T he Wriox Web-Developer Community - Mmrmoﬂ_lﬂt_tm_nlﬁ loter - Woy. B [of x|}

Help Topics To save changes to a document On the ]
e File menu, click Save.

Noie :

Using Web WordPro

You can alse save an existing document with a new name
[Create a document by clicking

Save As and then typing a new name in the File name box.
M‘M You can alse choese the format ef the file in the Save as
|Open a document

format box.

Figure B3: Help screen for users — save a document
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Appendix B

To open a document

1. On the File menu, chick Open.

2. In the Look In list, elick the drive that contains the
document you wani io open.

3. Double-click the folder that contains the document you
want io open.

4. Double-click the docwment.

Notes :

If you do not see the document you are looking for,

you can click a different file type in the Files of type box.
Yumwa&mmmﬂmﬂyhe&lﬁx
its name on the File menu

Figure B4: Help screen for users — open a document
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Appendix B

. 3.To paste text you have cut or copied, click the Edit
Copy aste & meru, and then click Pasie. is will paste the text at
|.1.,1m‘ ent the end of the document. _

4.To delete en,sebctﬂnmcﬂekﬁa Edit menw, and
: then click Delete.
{Print

e ] S |
Help Topics To cut, copy, paste, or delete text in
: Notepad
; 1.To cut text, select the text, click the Fdit menu, and
then click Cutl.
Create a
‘Sm a document 2.To copy text, select the text, click the Edit menu, and
then click Copy.
'Q!Q:I Q! cument

Figure B4: Help screen for users — copy, cut, paste & delete document
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Web WordPro Appendix B

R The Wiox Web-Developer Community - Microsoft Intemet | u?‘“"' rer : .I ".Z‘L!_I

Help Topics To change a font type, style, or size

1. Select the text whose format you want ts change.
2. On the Format menu, click Font .

|Using Web WordPro 3. jick the options you want.
I*Cream al To convert all the t;:xt to uppercase
|Save a document 1. On the Format menu, click Upper Caps

| a ; To convel;t all i_:lle l:ext tl-) lowercase
Copy, cut, paste & 1. On the Format menu, click Lower Caps

delete document g e e ), AN
Formating

To make sure only first letter of the
Print sentences and initial in uppercase

1. On the Format menu, click Clean Caps

To count the number of words

1. On the Fermai menu, click word count .

Figure B6: Help screen for users - formatting
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Web WordPro Appendix B

P (=
Help Topics To see how your document will look
| before you print it
Using Web ! 1. On the Print menu, click Print Preview.
{Create a document
To print document

|Save a document P

| a do ! 1. On the Print menu, click Print
ngm;‘_u!,gaste& e —
delete document .
Formating

Print

Figure B7: Help screen for users - print
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